Unterschiede
Hier werden die Unterschiede zwischen zwei Versionen angezeigt.
| Beide Seiten der vorigen RevisionVorhergehende Überarbeitung | |||
| edpweb3:faq [18.06.2026 13:56] – Jannis Baudisch | edpweb3:faq [29.09.2026 18:16] (aktuell) – Florian Karlstedt | ||
|---|---|---|---|
| Zeile 1: | Zeile 1: | ||
| - | ==== Häufige Probleme | + | ====== Häufige Probleme |
| - | === Kein Drag & Drop Effekt === | + | Hier sind Fehlerbilder gesammelt, die bei Installationen von **edp:**web immer wieder vorkommen. Die Ursache liegt dabei selten in **edp:**web selbst, meistens in der Umgebung davor, also im Reverse-Proxy oder in den Einstellungen des Betriebssystems. Jeder Abschnitt ist gleich aufgebaut: woran Sie das Problem erkennen, woher es kommt und wie Sie es beheben. |
| - | Wenn der Drag & Drop Effekt nicht funktioniert, könnte es daran liegen, dass WebSockets in Reverse-Proxy | + | ===== Drag & Drop funktioniert nicht ===== |
| - | === Lageführung wird trotz Aktivierung | + | Der Drag & Drop Effekt |
| - | Beim Start von **edp: | + | |
| - | D.h., wenn nach einem Neustart die Lageführung trotz Aktivierung innerhalb der Einstellungen nicht angezeigt wird, liegt dies daran, dass die entsprechende Lizenz nicht vorhanden ist. | + | **Ursache** |
| - | Sollte | + | Für diese Funktion braucht **edp:**web eine WebSocket-Verbindung. Ist im vorgeschalteten Reverse-Proxy |
| - | https:// | + | |
| - | Bitte beachten Sie hierbei auch, dass die Dienste unter dem Systembenutzer ausgeführt werden und für diesen andere Einstellungen als für das angemeldete Benutzerkonto gelten können. D.h. auch wenn alle Datumsformate in der Anzeige korrekt dargestellt werden, kann unter dem Systembenutzer eine andere Einstellung aktiv sein. | + | **Lösung** |
| + | In der Konfiguration des Reverse-Proxys den Upgrade-Header setzen und für die Weiterleitung HTTP/1.1 aktivieren. Beispiel für nginx: | ||
| - | === Taktische Zeichen werden nicht angezeigt (Fehler 404.11) === | + | <code nginx> |
| - | Wenn der IIS als Reverse-Proxy genutzt wird, kann es vorkommen, dass URLs mit einem Pluszeichen (+) abgewiesen werden – typischerweise mit dem HTTP-Fehler 404.11. Der IIS interpretiert das Pluszeichen standardmäßig als Versuch des „Double Escaping" | + | proxy_http_version 1.1; |
| - | Das hat folgende Auswirkungen in **edp: | + | proxy_set_header Upgrade $http_upgrade; |
| - | Lösung: Fügen Sie in der Datei web.config innerhalb des Bereichs | + | proxy_set_header Connection |
| + | </code> | ||
| + | Beim IIS muss zusätzlich das Windows-Feature " | ||
| + | |||
| + | ===== Lageführung wird trotz Aktivierung nicht angezeigt ===== | ||
| + | |||
| + | Die Lageführung ist in den Einstellungen von **edp:**web aktiviert, wird nach einem Neustart aber nicht angezeigt. | ||
| + | |||
| + | **Ursache** | ||
| + | |||
| + | Beim Start prüft **edp: | ||
| + | |||
| + | Wurde die Lizenz nachweislich inklusive Lageführung ausgestellt, | ||
| + | |||
| + | **Lösung** | ||
| + | |||
| + | Zuerst prüfen, ob die Lizenz die Lageführung enthält. Ist das der Fall, die Ländereinstellungen für den Systembenutzer nach der Anleitung [[server: | ||
| + | |||
| + | > **Hinweis: | ||
| + | |||
| + | ===== Taktische Zeichen werden nicht angezeigt (Fehler 404.11) ===== | ||
| + | |||
| + | Taktische Zeichen fehlen in **edp: | ||
| + | |||
| + | **Ursache** | ||
| + | |||
| + | Wird der IIS als Reverse-Proxy genutzt, weist er URLs mit einem Pluszeichen (+) standardmäßig ab. Er wertet das Pluszeichen als Versuch des " | ||
| + | |||
| + | **Lösung** | ||
| + | |||
| + | In der Datei '' | ||
| + | |||
| + | <code xml web.config> | ||
| < | < | ||
| - | < | + | |
| </ | </ | ||
| + | </ | ||
| + | |||
| + | Danach reicht der IIS die URLs unverändert an **edp:**web weiter und die taktischen Zeichen werden geladen. | ||
| + | |||
| + | > **Hinweis: | ||
| + | |||
| + | ===== Lange URLs werden nicht geladen (Fehler 400) ===== | ||
| + | |||
| + | Inhalte mit sehr langen URLs werden nicht angezeigt, vor allem taktische Zeichen von Sirenen oder POIs. Der Server antwortet mit Fehler 400. | ||
| + | |||
| + | **Ursache** | ||
| - | Damit reicht | + | Einer der Proxy-Server vor **edp: |
| - | === Lange URLs (insbesondere Taktische Zeichen von Sirenen oder POIs) werden nicht angezeigt (Fehler 400) === | + | **Lösung** |
| - | Dies kann an einem der vor dem **edp:**web liegenden Proxy Server liegen. | + | |
| - | Mögliche Ursachen: | + | * **Http.sys:** Der Registrierungswert |
| - | | + | |
| - | * IIS: Falls auf dem System | + | |